通达信副图指标【MACD背离指标】

指标名称:操盘手乾坤图;

 

加载效果:如上图;

通达信副图指标【MACD背离指标】

加载效果:如上图

使用平台:通达信;

使用方式:副图;

提示:本指标含有未来函数;

源码:

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;

DRAWTEXT(低位金叉,0.16,’ 低位金叉’),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,’ 二次金叉’),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;

DRAWTEXT(底背离,0.12,’ 底背离’),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,’三全项’),COLOR0000FF,LINETHICK2;

本文来自用户投稿,不代表千亿量化立场,请谨慎参考。转载本文请联系作者:深度工作室

发表评论

登录后才能评论