【通达信选股指标】早晨之星选股公式

通达信选股指标早晨之星选股公式

【使用平台】:通达信;

【使用方式】:选股器-条件选股;

【提醒】:本公式根据早晨之星形态编辑,可用于各周期,推荐日级别以上使用,下午两点半以后或收盘选股为最佳,需先补充历史数据。

【公式源码】

KST:=ABS(C-O);{K线实体部分高度};
RKST:=REF(KST,1);{上一交易日K线实体高度}
MKST:=MA(RKST,15);{15日K线实体高度平均值(不含当日)};
VAR1:=REF(O,2)>REF(C,2);{前日K线为阴线}
VAR2:=REF(KST,2)/REF(MKST,2)>1.3;{前日的K线实体部分是15日K线实体平均值的1.3倍以上}
VAR3:=REF(O,1)<REF(C,2);{昨天是低开的}
VAR4:=REF(H,1)>MAX(REF(C,1),REF(O,1))&&REF(L,1)<MIN(REF(C,1),REF(O,1));{昨日K线有上下影线}
VAR5:=(REF(H,1)-MAX(REF(C,1),REF(O,1)))<(MIN(REF(C,1),REF(O,1))-REF(L,1));{昨日K线上影线长度比下影线长度短}
VAR6:=REF(KST,1)/REF(MKST,1)<0.5;{昨日K线实体部分是15日K线实体平均值的0.5倍以下}
VAR7:=REF(V,1)<REF(V,2);{昨天的成交量小于前日成交量}
VAR8:=C>O;{今日K线为阳线}
VAR9:=O>REF(C,1);{今天是高开的}
VAR10:=V>REF(V,1);{今天的成交量大于昨日成交量}
VAR11:=C>(REF(C,2)+REF(KST,2)*0.67);{今天的阳线吃掉了前天阴线的3分之2以上}
VAR1&&VAR2&&VAR3&&VAR4&&VAR5&&VAR6&&VAR7&&VAR8&&VAR9&&VAR10&&VAR11;{执行条件选股};

本文来自用户投稿,不代表千亿量化立场,请谨慎参考。转载本文请联系作者:深度工作室

发表评论

登录后才能评论